Back to overview
Downtime

SSL certificate issue on our web app

Feb 25, 2026 at 04:54pm UTC
Affected services
Web App

Resolved
Feb 25, 2026 at 05:06pm UTC

This is resolved and we will keep monitoring the situation.

Created
Feb 25, 2026 at 04:54pm UTC

We're aware of an issue with our Azure cloud provider to do with SSL certificate provisioning, it should be back to normal shortly.